lnmp安装多个php版本后如何更改环境变量的php

用了lnmp一键安装包,发现自己越来越长见识啦,我的虚拟机中同时安装了两个版本的PHP,我每次php -v 时都是一个低版本的php,后来想直接用高版本了,就想着配置一下环境变量就搞定了,于是就安装环境变量的折腾,最后发现无论怎么调整都没办法更改过来,查看了lnmp的论坛才知道,只需要建一个软连接即可。

cd /usr/bin
sudo rm -rf php
cd /usr/bin
sudo ln -s /usr/local/php7.2/bin/php /usr/bin/php

再次执行 php -v
PHP 7.2.6 (cli) (built: Oct 18 2019 11:31:56) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

完美切换成功,就这么简单,傻眼不。

作者:PHP学习网,本文 lnmp安装多个php版本后如何更改环境变量的php 版权归作者,免费文章欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

发表评论